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Lesson 3: Using Formulas



how to use conditional summary functions



how to create and edit simple formulas



how to use text functions



how to use math operators and understand the
precedent order of calculations



how to use absolute and relative cell references





how to reference other worksheets

how to use mixed absolute and relative cell
addresses



how to use common functions



how to display and print formulas



how to use the SUBTOTAL function



how to use data validation

rE
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what formulas are

va



at

In this lesson, you will learn about formulas—what they are, how they work, how to insert simple formulas
and use built-in functions to create some formulas. Upon successful completion of this lesson, you will be
familiar with:

how to use a conditional function

Fo

Using Formulas
Creating and Editing Formulas
In Excel, every worksheet cell is capable of using a formula. A formula is simply a calculation involving
values, cell references, and/or built-in functions.
Worksheets typically contain formulas that refer to other worksheet cells. It is to your advantage to use cell
references in your formulas whenever possible rather than the actual values. When these values or amounts
change, the dependent cells (the cells containing the formulas) are automatically recalculated.
A formula can be up to 8,192 characters long. Enter your formula in the cell where you want the results to
appear. Formulas are easy to recognize – all of them begin with the equal sign (=).
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Suppose you have a worksheet with some formulas:

The formulas used in this worksheet are as follows:
Formula/Value

Description

A1

10

A constant value – numeric in this case. Every workbook with formulas will
usually have at least one constant value.

B1

=A1

References the current value in cell A1. No changes or calculations are
done to cell B1. If the value in cell A1 is changed, cell B1 will automatically
display the new value.

C1

=A1*8

References the value in cell A1 and multiply it by eight.

D1

=C1/5

References the value in cell C1 and divide it by five. Digits to the right of
the decimal point will also be displayed if necessary. Note that if the value
in cell A1 changes, then the value in cell C1 will change, which will cause
the value in this cell to change in a cascading effect.

E1

=SUM(A1:D1)

References a built-in function called SUM to calculate the sum total of all
cells in the range from A1 to D1. Note that if the value in cell A1 changes,
then the values in cells B1, C1, and D1 will also change at the same time,
which will cause the value in this cell to change as well.
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Cell
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Let’s change the value in cell A1. All of the formulas are automatically recalculated and the worksheet will
now appear as follows:

rE

va

This example demonstrates that by using formulas, you can have the computer do all of the work of
performing the calculations for you quickly, which is a significant time savings for you. You changed the
value in only one cell. Excel knows which sequence to perform all of the calculations, so that all of the
results will be correct.
Excel does not display the formula you type into a cell in the worksheet, only the result of the formula. To
view the formula, select the cell and you will see the formula and cell references in the formula bar. You can
also change a setting to display all formulas in a worksheet. This topic is covered later in this lesson.

Fo

You can also copy formulas to other cells. Excel will make a copy of the formula and the format while
automatically adjusting cell references for the offset distance and direction. This may appear illogical at
first, but it is actually a desirable feature in worksheets because the copied formulas are usually supposed
to refer to different sets of input values.
When you are entering formulas in a worksheet, Excel helpfully
prompts you when it detects an error or inconsistency in your
formula, with a suggestion for how to correct it.
Excel displays a
symbol for easy identification whenever a formula
has changed from a trend in the worksheet. This can be very handy if
you have to review the worksheet for differences or discrepancies.

60
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Cell References
Objective 4.1
After pressing the ‘=’ key to start the formula, there are two ways to enter a cell reference:


type the cell reference (or cell address) directly, or



click on the cells being referenced.

ly

The majority of formulas have one or more cell references. For example, you may set up a cell with a
formula to use the value from another cell, and perform a calculation on it. Cells B1, C1 and D1 in the
example worksheet above demonstrate this.
You can also set up another cell with a formula to perform a calculation with two or more cells, such as
=A1+B1, or =A1*B1+C4.

<starting cell address>:<ending cell address>

On

A third alternative is to create a formula that uses a function to operate on a range of cells. This is
demonstrated in cell E1 in the example worksheet above. A cell range is any rectangular block of cells,
written in this format:

rE
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An example of a cell range is C11:E18. Note the use of the “:” to separate the two cell addresses. These cell
addresses mark the two opposite corners of the rectangular group of cells. All cells inside this rectangle are
used together in the formula.

Cell ranges can only be used in functions or arrays, for example =SUM(C11:E18). You can’t use a cell range
on its own in a formula. The formula =F9+C11:E18 will result in an error in Excel.

Fo

The cell range can also be flat with all cells in the same row or column.
You can enter the cell range address in any sequence, as long as you use the cell addresses from the two
opposite corners. The follow cell range addresses are equivalent for the same range of cells: C11:E18,
E11:C18, C18:E11, E18:C11. Excel will accept every one of these range addresses and will change them to
C11:E18, marking the top left and bottom right corner cells.
Cell range addresses can also include entire rows or columns. For example, the formula =SUM(B:C) will
calculate the sum total of all values in columns B and C in the worksheet. Similarly, the formula =SUM(3:3)
will calculate the sum total of all values in row 3 in the worksheet.
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Mathematical Operators
Objective 4.1
The following show the symbols used in Excel to represent the standard mathematical operators:
^
*
/
+
–

Exponentiation and roots
Multiplication
Division
Addition
Subtraction

Brackets or parentheses
Negation (for example -2)
Exponents and roots
Multiplication and division
Addition and subtraction

On

1.
2.
3.
4.
5.
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You generally use formulas to perform calculations, such as ordinary arithmetic. Excel calculates formulas
using the standard precedence rule used in mathematics, as follows:
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Multiplication and division operators have the same level of precedence, so Excel performs them in the
sequence they appear starting from the left to the right. In the same manner, the addition and subtraction
operators are performed as they appear from left to the right.

at

You can alter this standard order of operation by placing components of the formula within parentheses.
Excel will then calculate the portion of the formula in parentheses before defaulting to calculations in the
order listed above. Thus, you can control the order of calculations in your formulas with careful use of
parentheses.

lu

Learn the Skill

This exercise demonstrates some of Excel’s formula capabilities.
Open the Quarterly Income Statement workbook and save it as Quarterly Income Statement ‐
Student. Be sure that the Quarter 1 worksheet is selected.

2

Select cell C8 and type: =c6+c7 (but do not press

va

1

yet).
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Excel now shows which cell(s) you selected as part of the formula. You can use this visual tool to see
what is happening on the screen when you set up a formula.

3

Press

to complete the formula.

4

Select cell C8 again.
In cell C8, Excel displays the number 6535, which is the sum of the numbers in cells C6 and C7. Note
the formula displayed in the Formula Bar.

62
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Formula displayed in the
Formula Bar

5

In cell C7, type: 125 and press

.

In cell D6, type: 6000 and press

.

On

6
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Excel has automatically recalculated the displayed value in cell C8 because it contains a formula that
refers to the values in cells C6 and C7, and a change in either (or both) cells will cause Excel to update
the total in cell C8. This demonstrates the advantage of using formulas in a worksheet and using a cell
reference rather than the cell contents.

This time, the displayed value in cell C8 does not change when you change the value in cell D6.
Remember that the formula in cell C8 has the cell reference to cell C6, not D6.

io
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Once you enter a formula into the worksheet, you can copy the formula to another location, if the formula
operation for the new location is the same. For instance, you can use the same formula to calculate the
total revenues for each of the next two months, except that you must use the respective cells for each of
those two months. Rather than entering the formula in each of the two cells twice, you can simply copy the
formula.
Select cell C8 and, on the Home tab, in the Clipboard group, click Copy.

8

Select cells D8 to E8 and, on the Home tab, in the Clipboard group, click Paste.

at

7

If you change a value in a referenced cell, all cells that depend on that value will also change.
9

Select each of the cells in the range C8 to E8.

lu

Notice that Excel has adjusted the formula in each of these cells. This is called relative addressing.
Now enter a similar formula, this time adding across three columns.

va

10 Select cell F4 and enter: Total.

11 Select cell F6 and enter: =C6+D6+E6.

rE

12 Select cell F6 again and copy this formula down to cells F7 to F8.
If a value is changed in one cell, Excel will recalculate all formulas that directly or indirectly reference
this cell automatically.

13 In cell E7, type: 80 and press

.

Fo

14 On the Quick Access Toolbar, click Undo to see that the displayed values in cells E7, E8, F7 and F8
change back to their previous values.
15 On the Quick Access Toolbar, click Redo to re-apply the change in cell E7.
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16 Select cell C8 and, on the Home tab, in the Clipboard group, click Copy.

17 Select the Quarter 2 worksheet, then select cells C8 to E8 and, on the Home tab, in the Clipboard
group, click Paste.

at

18 Select the Quarter 1 worksheet, then select cells F4 to F8 and, on the Home tab, in the Clipboard
group, click Copy.
19 Select the Quarter 2 worksheet, then select cell F4 and, on the Home tab, in the Clipboard group, click
Paste.

lu

20 Repeat steps 16 to 19 for the two remaining quarterly worksheets: Quarter 3 and Quarter 4.

va

The series of steps from 16 to 20 demonstrates one way of copying formulas from one worksheet to others.
The same end result can be achieved using fewer mouse clicks by doing step 16 first, then repeating step
17 for all three quarterly worksheets. Then do step 18, and repeat step 19 for the same three worksheets.
You can then do step 20. This may be faster because all you have to do is copy once and paste three times
(once for each worksheet). With more experience in copying and pasting, you will find your own shortcuts
to make tasks easier.

rE

21 Save and close the workbook.

What If Analysis

Fo

Spreadsheets can easily perform calculations such as simple arithmetic (such as add and multiply) on a
large volume of numbers. You don’t need an expensive computer to do this type of task. It can be done
easily even with a basic calculator because the problem only needs to be solved once and then the task is
completed.

Spreadsheets become invaluable when you need to perform what-if analysis, which involves repeating the
calculation of a set of formulas many times using different numbers. The trial-and-error method of doing
calculations is commonly used when there are multiple competing demands, and users try to find the best
compromise between the many choices to make. The name “what-if” describes the thinking process that
users face: “what if I change this number, then what will the result look like”.

A spreadsheet created to perform what-if analysis often uses simple formulas, although there will usually
be a large number of formulas.

64
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Learn the Skill
This exercise demonstrates Excel’s formula capabilities in helping with what-if analysis.

Open the Personal Budget workbook and save it as Personal Budget ‐ Student.

On

1

ly

Imagine that you are a prospective first-time home-buyer. This worksheet will help you determine how
large a mortgage you can assume given your current income level and spending priorities. Many financial
institutions rely on two calculations when deciding whether to approve a mortgage application: the gross
debt service and the total debt service. The gross debt service is the percentage of gross income required
to cover the basic costs of a house, including mortgage payments (principal and interest), property taxes,
heating, and condo fees. The total of this cannot exceed 32% of the buyer’s gross income. The total debt
service is the percentage of gross income required to cover the house and all other debts, such as credit
card payments and car loans. This percentage cannot exceed 40% of the buyer’s gross income.

First, calculate your monthly take home pay by reducing the monthly gross salary by 25%. This calculation
assumes that income taxes and other payroll deductions add up to 25% of your gross pay. You need both
your gross pay and take home pay amounts for these calculations.
Select cell B4, type: =b3*0.75 and press

.

io
n

2

Now calculate the excess of your take home pay over your expenses, which you accumulate as savings in a
bank account.
3

Select cell B22, type: =b4‐b20 and press

.

Select cell A7, type: Mortgage payments and press

.

lu

4
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At first glance, you appear to be ready to apply for a mortgage to buy your very first home! It seems
very reasonable that your current rent payments will become the new monthly mortgage payment, and
you can afford a home in that price range.

After looking at some homes, you can now estimate your property taxes and monthly condominium fees.
Select cell B8, type: 125 and press

6

Select cell B9, type: 100 and press

va

5

.
.

rE

Your income can no longer cover all of your expenses. You will have to cut back some of your
expenses.
7

Select cell B17, type: 100 and press

.

8

Select cell B14, type: 100 and press

.

Your cost cutting will have to include getting a smaller mortgage.
Select cell B7, type: 1285 and press

Fo

9

.

With your monthly expenses now under control, calculate the mortgage qualification ratios.

10 Select cell D3, type: =A7 and press

.

Notice that you can make a cell reference to a cell containing a text value, as demonstrated here.
11 Select cell E3, type: =B7 and press

.

Alternatively, you can copy the formula from cell D3 to cell E3. Excel will automatically adjust the
formula to reference the next cell to the right.
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12 Enter the following formulas in the specified cells:
D4
=A8
=A9
D5
D6
=A15
D7
Total housing costs
D8
Ratio (max 32%)

ly

Steps 10 to 12 demonstrate using formulas to copy values from one cell to another. In this group of cells,
selected numbers are taken from the personal budget and used for another calculation in a formula
entered in step 15 below. If the numbers in the personal budget are changed, these calculations are
updated at the same time.
13 Select cells D4 to D6 and, on the Home tab, in the Clipboard group, click Copy.

15 Enter the following formulas in the specified cells:
E7
=E3+E4+E5+E6
=E7/B3
E8

On

14 Select cell E4 and, on the Home tab, in the Clipboard group, click Paste.
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You calculate the gross debt service as 39% (0.39), which is higher than the maximum allowable 32%.
Now calculate the total debt service ratio.
D12
D14
D15
D16
D17
D18

=D7
=A11
=A18
=A19
Total debt costs
Ratio (max 40%)

at

16 Enter the following formulas in the specified cells:

lu

17 Copy the contents of cell D12 to cell E12.

va

18 Select cells D14 to D16, then click the AutoFill handle ( ) in the bottom right corner of this block and
drag it across to column E.

rE

19 Enter the following formulas in the specified cells:
E17
=E12+E14+E15+E16
E18
=E17/B3

Fo

You have calculated the total debt ratio as 55.25% (0.5525)—much higher than the maximum allowable
40%. You have too many debt (and other mandatory) payments to make every month to qualify for
this mortgage. You will need to make more adjustments in your lifestyle to qualify for a mortgage,
such as reducing or paying off your credit card debt, student loans, and car payments. You should also
consider looking for ways to increase your monthly income, such as changing to another job with
higher pay.

This is an unexpected surprise: your personal budget indicates that you can afford the mortgage payments,
but your financial institution requires two additional calculations to determine your eligibility. These
calculations seem unreasonable, but are in fact designed to prevent prospective home buyers from
accumulating more debt than they can handle, which may result in serious financial problems in the future
and possibly even personal bankruptcy or mortgage foreclosure.
Let’s assume that you delay buying your new home for several months and concentrate on paying off
debts. You were also able to improve your income by another $100 a month. Lastly, you reluctantly lowered
your expectations for a home, settling for a less expensive one.

66
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20 Enter the following values in the specified cells:
B19
100
0
B18
B7
1000
B3
4100

This income level is still not enough. Your Gross Debt Service Ratio (cell E8) is 31%, which is below the
maximum allowable rate of 32%. However, your Total Debt Service Ratio (cell E18) is 40.8%, which is
higher than the maximum allowable rate of 40%.

ly

Let’s assume that you are able to increase your income by another $100 a month.
21 Change the contents of cell B3 again to: 4200.

On

This demonstrates how you can use cell references very effectively in what-if analyses. The spreadsheet
contains many formulas, but they are calculated very quickly so that you can see the results when
adjustments are made. With these changes, you will be able to apply for a mortgage and be confident
that your application will be successful.

rE
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The completed worksheet should look similar to the following:

22 Save and close the workbook.

Referencing Other Worksheets

Fo

Objective 4.1

In addition to referencing other cells within the same worksheet, formulas can reference cells in other
worksheets within the same workbook. The general format of this kind of reference is:
‘<worksheet name>’!<cell reference>
Excel uses the ! symbol to indicate that this cell is located in a different worksheet. The single quotes are
required if the worksheet name has blank spaces in it.

Furthermore, you can also use cell references for cells located in a different workbook. This topic will be
covered in the Expert level courseware.
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Learn the Skill
This exercise demonstrates how to create formulas that reference cells located in other
worksheets.
1

Open the Quarterly Income Statement - Student workbook.

2

Click the Company worksheet tab to make it the active worksheet.

3

In cell C4, type: Qtr 1 and press

4

In cell C6, type: = (but do not press

5

Click the Quarter 1 worksheet and select cell F6.

.

ly

yet).

On

Notice that a marquee now appears around cell F6 and the formula bar shows =’Quarter 1’!F6 with
single quotes around the worksheet name.
6

Press

.

7

Copy the contents of cell C6 (in the Company worksheet) to cells C7 to C8 using your preferred
method.

io
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Notice that Excel automatically adjusts only the cell reference part, while keeping the worksheet
reference component unchanged.
Select cell C4. Then click the AutoFill handle ( ) in the bottom right corner and drag it across the
worksheet to column F.

9

Repeat steps 4 to 7 for the other three quarters in columns D to F.

va
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rE

10 Save the workbook.

Using Functions

Fo

Common Excel Functions
Objective 4.2

Typing cell addresses and plus signs is a good method when you are adding the contents of a small
number of cells. However, if you need to sum up a column of 50 numbers, this method is time-consuming
and will soon exceed the maximum limits on cell contents. It would be very inefficient to enter something
like “=B1+B2+B3+B4+…B50” for each cell you want to include.
Excel provides a large library of built-in functions to facilitate this and other types of mathematical and data
operations. These functions enable the calculation of long or complex formulas to be simplified by using a
specialized function. In this courseware, you will learn the most commonly used functions as well as some
more complex ones.

68
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An Excel function follows this general format:
=FUNCTION(arguments)

At first, it may appear that the number and variety of Excel functions is intimidating. The most commonly
used ones are similar to each other, and very easy to use. The functions you will learn in this lesson are:
Sum the range of specified cells.

=AVERAGE

Average the specified cells (total the range and divide the total by the number of entries).

=MIN

Display the minimum value of specified cells.

=MAX

Display the maximum value of specified cells.

=COUNT

Count the number of cells in the specified range that contain numeric values.

The Excel Expert courseware examines many of the other functions available.

ly

=SUM



Functions accept values (numeric, text or date, depending on the type of function) and cell references
as arguments within parentheses. Each function has specifications for its arguments but the most
common type of argument is a cell range. The format of the cell range is as follows:

io
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<first cell address>:<last cell address>
Examples:
A10:B15
D25:B5
C5:C25

Many functions allow you to enter a variable number of arguments. For example:

at



On

There are some general rules to understand regarding the arguments used in the functions:

=SUM(C6:C18) – calculates the sum of the numbers in all cells from C6 to C18

lu

=SUM(C6:C18,D6:D18,F6:F18) – calculates the sum of the numbers in all cells from C6 to C18, and D6
to D18, and F6 to F18
=SUM(C6:C18,C20) – calculates the sum of the numbers in all cells from C6 to C18, and cell C20

va

You can enter a cell range either by typing the cell reference(s) directly, or by using the pointing method.
To use the pointing method, simply use the mouse to click on the first cell and drag to the last cell to select
the cell range. The latter method has the advantage of visually identifying the cell range, which reduces the
possibility of entering incorrect cell references.

rE

An alternative to entering the SUM function into a cell is to use the AutoSum button in the Ribbon. Because
the SUM function is so commonly used, Excel provides three ways of activating it:


On the Formulas tab, in the Function Library group, click AutoSum (



on the Home tab, in the Editing group, click AutoSum (



You can also click Insert Function on the left of the formula bar.

), or

Fo

).

Note: If the Excel window is in Maximize view, this command appears as AutoSum. If the window is in
Restore view, this may appear as just an icon because the window is not wide enough to display the whole
button.
When using AutoSum, be sure to verify that you have selected the correct cell range.
Excel will automatically select the range of cells immediately above or to the left of the
selected cell, and display it for you to accept or change.
Notice that there is an arrow next to AutoSum. When you click the arrow, it will display
other summary functions that you can use in your formulas.
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Learn the Skill
This exercise demonstrates how to calculate the sum total of a row or column of numbers.
1

Ensure the Quarterly Income Statement - Student workbook is open.

2

Click the Quarter 1 worksheet tab and select cell C19.

3

On the Home tab, in the Editing group, click AutoSum.

4

lu
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Notice that the cell now shows =SUM(C11:C18), with the cell range C11:C18 highlighted, and a
marquee around that cell range. Excel also reminds you of other ways to enter this formula using
individual data values.

Press

to accept the formula as displayed.

rE
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Excel always includes the cell immediately above the active cell, even if it is blank, and extends up the
current column until it finds a blank cell. There are still numbers in the cells above the selected range,
but they are not automatically included because there is at least one blank cell between them. You can
manually extend the range to include additional cells.
5

Select cell C19 again and copy it to cells D19 to E19.

6

Select cell F11 and type: =SUM( but do not press

yet.

Fo

Note: You may enter cell references and the function name in lower or upper case characters. Excel will
convert them all to upper case.
7

Use the mouse to select the cell range C11 to E11. Then press

.

In this case, Excel permits you to omit entering the last parenthesis for this function. However, Excel
does not always permit this, and it is poor practice.

8

Select cell F11 again and copy it to cells F12 to F19.

Other arithmetic operations can be performed in a formula such as multiplication. If a cell contains a
formula that is different from the cells around it (if any), Excel displays a marker symbol.
9

Select cell F14.

10 Type: =C14+D14+E14 and press

70
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The worksheet should look similar to the following example:
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Note the
symbol in cell F14. This marker is a reminder that this cell contains a formula that is
different from the cells around it. It is not an error symbol because the different formula may be
intentional. To remove the symbol, click on the smart tag.

va
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11 Select cell F14 again, position the mouse over the smart tag, click the arrow and select Ignore Error.

12 Select cell C19 again and copy it to cells C19 to E19 in worksheets Quarter 2, Quarter 3, and Quarter 4.

rE

13 Select cell F11 in the Quarter 1 worksheet again and copy it to cells F11 to F19 in worksheets Quarter
2, Quarter 3 and Quarter 4.
14 Save and close the workbook.

Fo

There is no need to be concerned about the look of your worksheet. At this point, it is important to make
sure the data is accurate. Enhancing the look of the worksheet can take place later. We will look at
formatting in the next lesson.

Using the Subtotal Function
Objective 2.3

The SUM function calculates an arithmetical total of the selected cell range. In most situations, it is the
appropriate function for automatically adding together the value in multiple cells.
In some worksheets, you may already have SUM functions included in the data to calculate the subtotals
for subgroups of data. In these situations, it may be more appropriate to use the SUBTOTAL function.

3253-1 v1.00 © CCI Learning Solutions Inc.

71

Lesson 3

Using Formulas

The SUBTOTAL function does more than calculate a sum total for a range of cells. It actually performs a
variety of statistical operations, depending on which function number is used. The general format of the
SUBTOTAL function is:
=SUBTOTAL(Function #, Cell Range)
Function
AVERAGE—mean average of the cell range
COUNT—number of cells containing numeric values
COUNTA—number of non-blank cells
MAX—highest value in the cell range
MIN—lowest value in the cell range
SUM—sum total of the cell range

Other function numbers that are also available for SUBTOTAL are:

Function
PRODUCT (all numbers multiplied together)
STDEV.S (standard deviation based on a sample)
STDEV.P (standard deviation based on entire population)
VAR.S (variance based on a sample)
VAR.P (variance based on entire population)

io
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Function #
6
7
8
10
11

On

Function #
1
2
3
4
5
9

ly

The most commonly used function numbers are:

at

The primary advantage of SUBTOTAL over SUM is that it will not include any other SUBTOTAL calculations
within its range. As a result, you can insert subtotal, total, and grand total calculations into a table—without
any risk of accidentally double-counting a subtotal—by simply including the entire range of cells.
To insert the SUBTOTAL function, use one of the following methods:
Click Insert Function and then, in the Or select a category field, click Math & Trig, or



on the Formulas tab, in the Function Library group, click Math & Trig, or



type the formula directly into the cell.

lu



va

Learn the Skill

This exercise demonstrates the use of the SUBTOTAL function.
Open the Weekly Expense Report workbook and save it as Weekly Expense Report – Student.

rE

1

First, use the traditional SUM function to calculate the subtotal values in column C.
Select cell C6 and then, on the Home tab, in the Editing group, click AutoSum. Verify that only cell C5
is selected as the argument for the SUM function and press
.

3

Select cell C9 and then, on the Home tab, in the Editing group, click AutoSum. Verify that only cell C8
is selected as the argument for the SUM function and press
.

4

Select cell C13 and then, on the Home tab, in the Editing group, click AutoSum. Verify that both
expense values in the cells above are selected and press
.

5

Repeat either step 3 or 4 (depending on whether there is one or two values to add together) for each
of the remaining subtotal cells in cells C17, C21, C24, E6, E9, E13, E17, E21, and E24.

Fo

2
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Up to this point, both columns C and D have been identical. The subtotal values have been calculated for
each travel office. You will now try to calculate the grand total for all offices.

at

To do this, you will deliberately create an incorrect grand total for column C, which you will use for
comparative purposes.
Select cell C25 and then, on the Home tab, in the Editing group, click AutoSum. Select cells C5:C24
and press
.

7

Enter the following formulas:
Formula

=AVERAGE(C5:C24)
=COUNT(C5:C24)
=MAX(C5:C24)
=MIN(C5:C24)

va

Cell
C26
C27
C28
C29

lu

6

rE

Now enter the correct formulas for column E. The grand total of =SUM(E6,E9,E13,E17,E21,E24) calculates
based only on the subtotal values.
8

Select cell E25 and then, on the Home tab, in the Editing group, click AutoSum.

Fo

To select individual cells instead of the full range as you did in step 6, you must use the
9

Select cell E6, hold down the
Release the
key and press

key.

key, and then click on each of cells E9, E13, E17, E21, and E24.
.

Notice that the grand total in column E is half of the grand total in column C. This demonstrates that
the latter value is double-counting everything in column C.

Now calculate the average weekly expense for all employees
10 Select cell E26 and enter the following formula:
Cell
E26

Formula
=AVERAGE(E5,E8,E11,E12,E15,E16,E19,E20,E23)
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Note that the cells in this AVERAGE function are not the same as for the SUM function above. The
average is calculated using each individual person’s expense amount, not the subtotal for the office.
11 Enter the rest of the summary formulas:
Cell
E27
E28
E29

Formula
=COUNT(E5,E8,E11,E12,E15,E16,E19,E20,E23)
=MAX(E5,E8,E11,E12,E15,E16,E19,E20,E23)
=MIN(E5,E8,E11,E12,E15,E16,E19,E20,E23)

As you can see, steps 10 and 11 were painful—they were tedious and error-prone.

ly

Alternatively, you can repeat steps 8 and 9 to use the AutoSum button in the Ribbon to make it easier:
click the arrow for AutoSum, select the desired summary function, then use the
key to select each of
these cells.

rE

va

lu

at

io
n

On

Note: For step 11, you can also copy the AVERAGE formula from cell E26 to these cells, and change the
function name. You will need to change the cell references to absolute cell references before copying it.
Absolute cell references are covered later in this lesson.

Now use the SUBTOTAL function and see how it works.

Fo

12 Select cell G6 and enter: =SUBTOTAL(9,G5).

13 Now enter the remaining subtotal formulas:
Cell
G9
G13
G17
G21
G24

Formula
=SUBTOTAL(9,G8)
=SUBTOTAL(9,G11:G12)
=SUBTOTAL(9,G15:G16)
=SUBTOTAL(9,G19:G20)
=SUBTOTAL(9,G23)

Note that you can select the cell or cell range instead of typing the cell reference addresses into the
function, if that is easier for you.
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14 Select cell G25 and enter: =SUBTOTAL(9,G5:G24).
Enter the remaining statistical functions using SUBTOTAL.
15 Enter the following formulas:
Cell
G26
G27
G28
G29

Formula
=SUBTOTAL(1,G5:G24)
=SUBTOTAL(2,G5:G24)
=SUBTOTAL(4,G5:G24)
=SUBTOTAL(5,G5:G24)

va

lu

at

io
n

On

ly

Step 15 was much easier to do than step 10 because you simply selected the entire cell range in the
column (including the grand total). The SUBTOTAL function simply ignored the presence of any other
SUBTOTAL function within that cell range. As a result, column G shows the same results as column E. It
was just as easy in column C to enter those formulas, but the results were incorrect.

rE

16 Save and close the workbook.

Conditional Functions

Fo

The ability to perform different calculations based on changing values is one of the most powerful and
useful features of spreadsheets. The primary function used for this is the IF function. This function makes an
evaluation or logical test and performs one of two different calculations based on the result. This automatic
evaluation provides “on the fly” conditional worksheet calculations.
The format of the IF function is as follows:
=IF(logical test,value if true,value if false)

Logical Test

Specify what the IF statement will evaluate.

Value if True

If the Logical Test is found to be true, then the result of the IF function will be whatever
is in this section of the formula.

Value if False

If the Logical Test is found to be false, then the result of the IF function will be whatever
is in this section of the formula.
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The Logical Test section of the function often uses comparison operators that will help you obtain the
desired result. Qualifiers are punctuation marks used to identify or define different types of data. For
example, text used in a formula requires double quotes as qualifiers.

ly

Some of the comparison operators you can use are:
=
Equal to
>
Greater than
<
Less than
>=
Greater than or equal to
<=
Less than or equal to
<>
Not equal to

On

The Value if True/False sections can contain a text string, values or even other functions. In fact, you can
nest or embed up to 64 IF functions within one IF function. An example of a nested IF function would
appear as follows:
=IF(A1=10, “text A”,IF(A1=20, “text B”, “text C”))
In this example, Excel will display the following values when the conditions are met:
Then this will display
text A
text B
text C

Learn the Skill

io
n

If A1 contains
10
20
Any other value

at

This exercise demonstrates how to use the IF function

1

lu

You will use a worksheet that will calculate the number of travel points given to customers based on the
amount they spend. For every dollar a customer spends, the program awards 100 AirKm points. In addition,
the program awards customers an additional 20 points for every dollar if the total amount is over $500.
Open the AirKm Awards workbook and save it as AirKm Awards - Student.

va

First, calculate the number of points per dollar.
2

Select cell D5, type: =C5*100 and press

3

Select cell D5 again and copy it down to cells D6 to D20.

.

rE

Now calculate the bonus points per dollar, but only do this where the amount is greater than 500.
Select cell E5, and click Insert Function.

5

In the Or select a category list, click Logical.

6

In the Select a function list, click IF and click OK.

Fo

4

Excel displays the Function Arguments dialog box to help you enter the correct arguments for this
function. You will base the conditional on the cost of travel, which is in cell C5, and must be over 500.

7

In the Logical_test field, type: C5>500.

The next section is the Value_if_true section. If the result of the conditional test (C5 > 500 in this case) is
true, Excel will return the value in this box to the worksheet cell. In this case, the value has to be calculated.
8

In the Value_if_true field, type: C5*20.

The last part of the function is the Value_if_false section. If the result of the conditional test is false, Excel
will return this value. In this case, the value would be zero.
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ly

In the Value_if_false field, type: 0.

10 Click OK.
Note that the resulting formula is =IF(C5>500,C5*20,0).

On

9

11 In cell E5, press

.

io
n

Since the calculated value could result in a decimal value, you can use an additional rounding function to
round the value up or down to the nearest whole number. You can accomplish this by embedding the IF
function inside the ROUND function.

12 Move the cursor inside the cell to the left, to a position between the = and IF, and type: ROUND(
key, type: ,0) and press

.

at

13 Press the

14 Copy the formula from cell E5 to cells E6:E20.

Fo

rE

va

lu

Bonus points are now calculated only if the amount in column B is greater than $500.

15 Save the workbook.

You can modify your IF function if you want a more presentable worksheet. For example, if you want the IF
formula to show a blank cell instead of zeros or dashes when the amount is $500 or less, modify the
formula to appear as follows:
=ROUND(IF(C5>500,C5*20,""),0)
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The set of double quotes will cause Excel to insert a blank in any cell that proves FALSE based on the
argument in the Logical_test.
To have either example work properly, remember to copy the changed formula to the other cells on the
worksheet.
When using the Insert Function, Excel will insert the quotes for you when entering text in the Value if
True/False fields. When you want either of these fields to be blank, you must type both quotation marks or
the word True or False will appear in the cell.

ly

Using Conditional Summary Functions
Objective 4.3

On

The summary functions AVERAGE, COUNT, and SUM will simply perform the calculations on a range of
cells. The conditional function IF allows you to perform one of two different calculations, depending on the
results of a logical test. These two can be combined together into what are known as conditional summary
functions: AVERAGEIF, COUNTIF, and SUMIF.

io
n

AVERAGEIF Calculate the average value of all cells in a range which meet the logical test. The format of
this function is as follows:
AVERAGEIF(criteria_range, logical_test, average_range)
The average range is optional. If it is not specified, it is assumed to be the same as the
criteria range.
Count the number of cells in a range that contain a non-blank value and meet the logical
test.
COUNTIF(criteria_range, logical_test)

SUMIF

Calculate the sum total of all cells in a range which meet the logical test.
SUMIF(criteria_range, logical_test, sum_range)
The sum range is optional. If it is not specified, it is assumed to be the same as the criteria
range.

lu

at

COUNTIF

An example of a conditional summary function is:

va

=SUMIF(D4:D207,"Visa",F4:F207)

rE

In this function, the criteria range is D4 to D207, the sum range is F4 to F207, and the logical test is “Visa”.
Therefore, Excel will examine each of the cells in the range D4 to D207. If the cell contains the value “Visa,”
the corresponding numeric value in the cell range F4 to F207 will be included in the sum total.
These functions are different from the IF function in that a more flexible logical test is used. With an IF
function, you can only specify one logical test which must result in a TRUE or FALSE value, and this
generally requires the use of a comparison operator.

Fo

A conditional summary function will apply the logical test to each and every cell in the range you specify
(D4 to D207 in the example above). And if you do not specify a comparison operator, Excel will assume you
want to use the “=” operator, for example, =SUMIF(D4:D207,"=Visa",F4:F207) is the same as
=SUMIF(D4:D207,"Visa",F4:F207).
The logical test may be a fixed value or a cell reference. The SUMIF formula above is an example of a fixed
value test by comparing each cell in the range D4 to D207 to determine if it is equal to the value of “Visa”.
An example of a cell reference is =SUMIF(E4:E207,”>”&B2). Notice that only the comparison operator is
inside double-quotes, and the cell reference must be preceded by the & symbol.
The average_range and sum_range are optional. For the AVERAGEIF and SUMIF functions, you can perform
the logical test on one cell range, and perform the AVERAGE or SUM calculation on a different cell range.
This option makes these functions more flexible to use.
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Learn the Skill
This exercise demonstrates the use of conditional summary functions.
1

Select the AirKm Awards – Student workbook.

Enter text into cells to help identify the function of the first set of conditional formulas.
Enter the following text into cells:
Cell
G5
G6
G7

Text
Sales Over $500
Total Sales Over $500
Avg Sales Over $500

ly

2

Enter the following formulas into cells:
Cell
H5
H6
H7

Text
=COUNTIF(C2:C20,">500")
=SUMIF(C2:C20,">500")
=AVERAGEIF(C2:C20,">500")

io
n

3

On

Now enter the conditional summary formulas.

at

If you want to enable an advanced feature of these conditional summary functions, you can enter the
logical test into worksheet cells instead of into each of the formulas. For example, suppose cell H5 has the
formula =COUNTIF(C2:C20,G15), and cell G15 contained the text string >500. Referencing a cell that
contains the test criteria makes it easier to change the logical test and avoid forgetting to change a
function that contains the test criteria.

lu

Notice that the SUMIF and AVERAGEIF conditional formulas used here perform their calculations on the
same column in which the test criteria are applied. In other words, these formulas select only those cells
that meet the stated criteria and then perform the COUNT, SUM, and AVERAGE on only those cells. The
significance of this will become clearer as you examine the next set of conditional formulas.

4

va

Now enter conditional summary formulas that pertain only to rows where the sales type is “Corporate.”
Enter the following text into cells:
Text

Corporate Sales
Total Corporate Sales
Average Corporate Sales

rE

Cell
G9
G10
G11

5

Enter the following formulas into cells:

Fo

Cell
H9
H10
H11

Text

=COUNTIF(B2:B20,"Corporate")
=SUMIF(B2:B20,"Corporate",C2:C20)
=AVERAGEIF(B2:B20,"Corporate",C2:C20)

These are the same conditional formulas as used previously, except that an additional argument has
been added to the SUMIF and AVERAGEIF. In this variation, the test criteria are applied to the cells in
column B (= “Corporate”), but the SUM and AVERAGE are applied to the corresponding cells in column
C, which is where the sales amounts are located. The average value can be verified by dividing the sum
value into the count value.
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8

Save and close the workbook.

io
n

Using Text Functions

On

ly

The worksheet should now appear as follows:

Objective 4.4

Excel includes several text-oriented functions that are useful for handling text strings. They are often used
to manipulate data imported from other sources. Some of the most useful text functions include:
Extract the specified number of characters starting from the left side of the text string.
The format of this function is: LEFT(text_string, number_of_characters)

at

LEFT

lu

The text_string can be a cell range. If number is greater than the total length of the
text string, then the shorter text string is returned and extra blank characters will not
be padded on the right.
Extract the specified number of characters starting from the right side of the text
string. The format of this function is: RIGHT(text_string, number_of_characters)

va

RIGHT

rE

The text_string can be a cell range. If number is greater than the total length of the
text string, then the shorter text string is returned and extra blank characters will not
be padded on the left or right.

Fo

MID

UPPER

LOWER

Extract the specified number of characters starting from any position in the text string.
The format of this function is:
MID(text_string, starting_position, number_of_characters)
The text_string can be a cell range. If number is greater than the number of characters
available, then the shorter text string is returned and extra blank characters will not be
padded on the right.
Convert all characters in a text string to uppercase. The format of this function is:
UPPER(text_string)
Convert all characters in a text string to lowercase. The format of this function is:
LOWER(text_string)

PROPER

80

Convert the first letter of the text string and any letter following a non-alphabetic
character to uppercase. All other characters are set to lowercase. The format of this
function is: PROPER(text_string)
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CONCATENATE Join two or more text strings together to create one text string. Alternatively, the &
operator can be used instead of the CONCATENATE function. The format of this
function is: CONCATENATE(text_string_1, text_string_2, text_string_3, …)
When spreadsheets are used for lists or as a database, these often overlooked functions can save many
hours of manually entering data.

Learn the Skill
This exercise is designed to demonstrate how text functions can be used to change character
strings.
Create a new, blank workbook.

2

Enter the following values (be sure to use the upper and lower characters as specified here):
Cell
Value
A1
JaNe
pArkER‐smiTh
B1

3

Increase the width of columns A, B, and C to 22.

4

Select cell C1 and type: =CONCATENATE(A1," ",B1). Be sure to place one blank space between the
quotation marks.

io
n

On

ly

1

The space between the quotation marks is required to separate first and last names.
Select cell A2 and type: =LOWER(A1).

6

Select cell A3 and type: =UPPER(A1).

7

Select cell A4 and type: =PROPER(A1).

8

Copy cells A2:A4 to B2:C4.

at

5

lu

Notice that Excel inserts capitals in all the proper locations, including after the hyphen.
Now use other text functions to extract parts of text strings or join them together in different ways.
9

In cell A6, type: BIRTHDAY

va

10 In cell B6, type: =LEFT(A6,5).

11 In cell C6, type: =RIGHT(A6,3).

rE

12 In cell B7, type: =CONCATENATE(LEFT(A6,3),MID(A6,6,1)).
You will find the & operator to be easier to use than the CONCATENATE function, and it creates the same
result.

Fo

13 In cell C7, type: =LEFT(A6,3)&MID(A6,6,1).

14 Save the workbook as Text Functions – Student and close it.
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Using Absolute and Relative Cell References
Using Absolute Cell References
Objective 4.1

ly

Most formulas in an Excel worksheet use relative addressing for cells. If you copy a formula that contains a
relative cell address and paste it to another cell, Excel automatically adjusts it for the new location. For
example, suppose you have a formula that adds three rows together within one column. You can copy this
formula to another column to add the adjusted set of three rows in the new column. The formula is relative
to the column in which you place it.

On

This automatic adjustment feature is advantageous when you are creating sheets, such as budget sheets,
which require the same formula to be repeated across many months or line items. However, in some cases
you may not want this automatic adjustment feature.
Fortunately, Excel enables you to make cell addresses absolute or fixed. An absolute cell address refers to a
fixed (non-moving) location on the worksheet.

io
n

To change a relative cell address to an absolute (fixed) cell address in a formula or function, enter a dollar
sign before the row number and/or column letter (for example, $E$5). This ensures that when you copy a
formula, Excel will not adjust the absolute cell addresses for the new location.
Another method to obtain the absolute signs in cell addresses is to press
once you have typed the cell
address. You can also go back to formulas you have typed previously, edit them, position the insertion
point in the cell address you wish to make absolute and press
.
determines which references become absolute:

at

The number of times you press

Press once to make both the column and row reference absolute.



Press twice to make only row references absolute.



Press three times to make only the column reference absolute.



Press four times to remove the absolute references on both column and row.

lu



Objective 4.1

va

Using Mixed Absolute and Relative Cell References

rE

Cell addresses do not have to have both absolute column and row references. You can have mixed cell
references. The column reference can be absolute and the row reference relative (for example, $E5). If a
formula including this reference is copied to a new location, only the column reference ($E) is constant, and
the row reference is adjusted for the new location.

Fo

Conversely, if you copy a formula including a cell reference with an absolute row reference and a relative
column reference (for example, E$5) to a new location, Excel will adjust only the column reference for the
new location. This adds flexibility for creating cell formulas, which will become increasingly important as
your worksheets become more complex.
As a general rule of thumb: if you intend to copy the formula to other cells in the same row and keep the
column reference locked, place the $ in front of the column letter. If you intend to copy the formula to
other cells in the same column and keep the row reference locked, place the $ in front of the row number.

82
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Learn the Skill
This exercise demonstrates the use of absolute cell references.
1

Open the Quarterly Income Statement - Student workbook. If necessary, click the Company worksheet
tab.

First create a new column of totals.
Select cell G4 and type: Total.

3

Select cells C6 to G8 and on the Home tab, in the Editing group, click AutoSum.

4

In cell C11, type: = then click the Quarter 1 worksheet and select cell F11 and press

5

Repeat step 4 for other cells in this row:
Cell
Source
D11
Quarter 2 worksheet cell F11
E11
Quarter 3 worksheet cell F11
F11
Quarter 4 worksheet cell F11

6

Select cells C11 to G11 and on the Home tab, in the Editing group, click AutoSum.

7

Copy the contents of the cell range C11 to G11 down to cells C12 to G19.

ly

2

io
n

On

.

The relative addressing feature in Excel has saved you a lot of time in setting up these formulas.
Select cell A21 and type: Profit.

9

Select cell C21 and type: =C8‐C19.

at

8

10 Copy cell C21 across to cells D21 to G21.

lu

11 Select cell A22 and type: Quarterly Margin.
12 Select cell C22 and enter: =C21/G8.

va

13 Copy cell C22 across to cells D22 to G22.

Fo

rE

At first, it appears as if you can copy the formula into the other cells in row 22. However, the result is as
shown in the following:
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Clearly, the answers provided are incorrect—Excel displays a #DIV/0! (division by zero) error message
in the other cells. Now examine the formulas you had copied in column C.
14 Select cell D22 and examine the formula bar.

ly

As you can see, Excel has adjusted the cell address using relative addressing for each cell where you
copied the formula. This adjustment process, which was so useful when you were creating and copying
other formulas, is now causing a problem: dividing a value in cell D21 by the value in cell H8. The
problem is that cell H8 is blank, which is interpreted as having the value of zero. If you divide any
number by zero, you will get a “division by zero” error message.

15 Select cell C22 and press
16 Press

to activate the editing mode.

On

You can resolve this problem by returning to cell C22 and editing the formula. The formula must use
absolute cell referencing for the G8 cell reference. Thus, the formula in cell C22 should be =C21/$G$8
or =C21/$G8.

to put the absolute value signs around the nearest cell reference in the formula (G8).

17 Press

to accept this formula.

io
n

Note that the amount in cell C22 does not change.

18 Copy the formula from cell C22 to cells D22 through to G22.

Fo

rE

va

lu

at

Your worksheet should now look like the following example:

Check the formulas now entered in column C:
C22
D22
E22
F22
G22

contains
contains
contains
contains
contains

=C21/$G$8
=D21/$G$8
=E21/$G$8
=F21/$G$8
=G21/$G$8

When the reference to cell G8 is absolute, it is anchored to the total revenues cell.
19 Save the workbook.
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Displaying and Printing Formulas
Objective 1.4
To see the formula in a cell, you must select that cell and examine the formula displayed in the Formula Bar,
or press
to see the formula in the cell. In some circumstances, you may want to see all the formulas in
all the cells at the same time, especially when you are verifying the accuracy of the spreadsheet. Excel has
an option available to display all formulas in a worksheet at the same time. Cells that contain numeric or
other values will simply display those data values.

ly

Excel allows you to print the worksheet with the formulas displayed. This is an excellent technique for
verifying that you have entered all the formulas correctly.

On

Learn the Skill

This exercise demonstrates how to display the formulas in worksheet cells, or to display the
formula results.
If necessary, open the Quarterly Income Statement - Student workbook.

2

Click the File tab, then click Options.

3

Click Advanced in the left pane of the Excel Options dialog box.

4

Scroll down to the Display options for this worksheet group of options.

5

Verify that you have set the display options box to Company, and then click the Show formulas in
cells instead of their calculated results check box.

io
n

1

Fo

rE

va

lu

at

Hint: An alternative way of activating this feature is to use the keyboard shortcut key sequence
CTRL+ `(GRAVE ACCENT).

6

Click OK.

7

If necessary, increase the size of the workbook window.
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To turn off the display of the formulas, repeat the same steps but clear the check box.
Click the File tab, then click Options.

9

Click Advanced in the left pane of the Excel Options dialog box.

io
n

8

10 Scroll down to the Display options for this worksheet group of options and clear the Show formulas in
cells instead of their calculated results check box. Click OK.

at

You can also print the worksheet with the formulas displayed.
11 Close the workbook and discard any changes.

lu

Data Validation
Objective 1.3

rE

va

Electronic spreadsheets first appeared as very crude blank sheets. You could enter any type of value in any
cell and the spreadsheet would attempt to cope with it. For example, even if it seemed like there should be
a numeric value in a cell, Excel would accept a text string in it. If that cell were subsequently used in a
calculation, Excel treated that cell as if it contained the value 0 (zero). This flexibility (or, described another
way, the willingness of the spreadsheet to accept anything anywhere without many complaints) made
spreadsheets very popular with novice computer users.

Fo

However, this flexibility often resulted in undesirable side effects when wrong values were entered into
certain cells. For example, the upper case letter “O” can
be mistakenly entered instead of the number “0” and the
lower case “l” can be mistaken for the number “1” in
some character fonts.
Excel can prevent this with the Data Validation feature
which displays a helpful message whenever the user
selects a particular cell or an error message if an incorrect
value is entered.

86
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You can choose from different data types as validation checks:

Deactivate any data validation. This is the default setting for all cells. However, you
can also use it to display an input message without validating any data entry.

Whole number

Allow only numeric values without any decimal digits.

Decimal

Allow any numeric value.

List

Allow selections from a defined list of values in a cell range. This is also known as a
pick list.

Date

Allow only date values. The lowest date value is January 1, 1900.

Time

Allow only valid time values.

Text length

Allow only the specified number of text characters. This validation does not permit
any numbers, dates, or time values to be entered.

Custom

Enter a formula to validate the data being entered into the cell. The result of the
formula must be a true or false value.

On

ly

Any value

Learn the Skill

io
n

This exercise demonstrates how to use the Data Validation feature.

Open the Feedback Form workbook and save as Feedback Form – Student.

2

Select cell B10. On the Data tab, in the Data Tools group, click Data Validation. If you clicked the
drop-down button below the Data Validation button, click Data Validation.

3

Enter or select the following options for the Settings tab and click OK:

lu

Select
Whole number
between
1
5

Fo

rE

va

Criteria
Allow
Data
Minimum
Maximum

at

1

Now try entering an invalid rating value and observe the results.
4

Select cell B10. Type: 0 and press

.

Excel displays the default error message.
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Click Cancel.

You can customize this error message to help users understand what values are valid or invalid.
Select cell B6. On the Data tab, in the Data Tools group, click Data Validation.

7

Enter or select the following options for the Settings tab:

On

Select
Date
less than
=TODAY()

8

lu

at

io
n

Criteria
Allow
Data
End date

ly

6

Click the Error Alert tab, enter the following settings, and click OK:
Enter
Stop

va

Criteria
Style
Title
Error message

Fo

rE

Incorrect date
Your travel date must be before today.

9

Select cell B6 and enter a future date.
Your customized error message is now displayed.

88
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10 Click Cancel.
You can also display a helpful message when a cell is selected.
11 Select cell B13. On the Data tab, in the Data Tools group, click Data Validation.
Select
Text length
less than
150

On

Criteria
Allow
Data
Maximum

ly

12 Click the Settings tab and enter or select the following:

13 Click the Input Message tab, enter the following settings, and click OK:

va

lu

at

io
n

Criteria
Enter
Title
Your comments
Input message Your comments will be entered into a grand prize draw!

Fo

rE

Your customized input message is now displayed.

14 Click on another worksheet cell and then click on cell B13 again to see the input message display
again.
15 Test the worksheet by entering values of your own choosing into the various cells.
16 Save and close the workbook.
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Lesson Summary
In this lesson, you learned about formulas—what they are, how they work, how to insert simple formulas and
how to use built-in functions to create some formulas. You should now be familiar with:
what formulas are



how to use conditional summary functions



how to create and edit simple formulas



how to use text functions



how to use math operators and understand the
precedent order of calculations



how to use absolute and relative cell references





how to reference other worksheets

how to use mixed absolute and relative cell
addresses



how to use common functions



how to display and print formulas



how to use the SUBTOTAL function



how to use data validation



how to use a conditional function

On

ly



MMM

Review Questions

Go online for Additional Review and Activities

List which standard math operators Excel uses and what is their order of precedence.

2.

Give examples of how using formulas to perform a what-if analysis is beneficial to you.

3.

Which of the following are invalid?
=MAX(B5:B15)

b)

=MAX(B5,B6,B7,B8,B9,B10,B11,B12,B13,B14)

c)

=MAX(B5:B7,B8:B10,B11:B15)

d)

=MAX(B1,B5:B8,B9:B15)

e)

All of the above are invalid formulas

f)

None – all are valid formulas

g)

c

h)

b, c, and d

va

lu

at

a)

Define the different parts of a reference to other worksheets using the reference Tours!B4 as an
example.

rE

4.

io
n

1.

What is the main difference between an IF function and other functions discussed in this lesson such as
SUM, AVERAGE, and UPPER?

6.

Are the LEFT and MID functions fully interchangeable? In other words, can you always use the LEFT
function instead of MID, as well as using MID instead of LEFT?

Fo

5.
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7.

Explain the difference between absolute and relative cell references.

8.

Provide examples of when or why it may be beneficial to print the formulas in the worksheet.
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